Jump to content
MDDHosting Forums

php.ini questions


skunkbad
 Share

Recommended Posts

I've purchased a basic shared hosting account today, and have been setting it up in the last couple of hours. I have a php.ini file in my public_html directory, and the contents of it is simply:

 

[PHP]
date.timezone = America/Los_Angeles

 

Normally this prevents a warning from PHP, but for whatever reason, it doesn't seem to work for me on my new account. Do I need to do something different? Here's the warning:

 

An error occurred in script '/home/brianswe/public_html/application/views/template_content.php' on line 66:
<br />date() [<a href='function.date'>function.date</a>]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead

 

I'd also normally turn on zlib.output_compression in the php.ini, but I'm guessing that if the date.timezone setting isn't working, then this won't either.

 

What do I need to do?

Link to comment
Share on other sites

I've purchased a basic shared hosting account today, and have been setting it up in the last couple of hours. I have a php.ini file in my public_html directory, and the contents of it is simply:

 

[PHP]
date.timezone = America/Los_Angeles

 

Normally this prevents a warning from PHP, but for whatever reason, it doesn't seem to work for me on my new account. Do I need to do something different? Here's the warning:

 

An error occurred in script '/home/brianswe/public_html/application/views/template_content.php' on line 66:
<br />date() [<a href='function.date'>function.date</a>]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead

 

I'd also normally turn on zlib.output_compression in the php.ini, but I'm guessing that if the date.timezone setting isn't working, then this won't either.

 

What do I need to do?

We don't support php.ini and you have to make your PHP settings changes in your .htaccess file - we also support iniset(). As for compression - we do have GZIP compression on by default if that is what you are trying to achieve.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...