Jump to content


Photo

Extremely Slow WordPress Performance

performance slow wordpress php mysql

  • Please log in to reply
3 replies to this topic

#1 Flix

Flix

    Newbie

  • Members
  • Pip
  • 14 posts

Posted 04 November 2012 - 08:19 PM

I'm currently developing a site and I'm noticing extremely slow performance on WordPress, under any scenario. Here's the info:
  • Shared account running on Jasmine
  • WordPress 3.4.2, PHP 5.3, MySQL 5.5.27
  • Default theme; no plugins
  • A "clean" database with just a few posts for testing
  • Zero external usage (no visitors yet)
The slowness apparently is not influenced by time-of-the-day or day-of-the-week; it happens randomly but very often... about once every 3-4 accesses. For example:
  • Loading the home (or any other) page: 10 to 15 seconds
  • Loading any admin (WP backend) page: 10 to 15 seconds
  • Loading an item list (e.g. posts page): very slow, posts loading one-by-one*
* I've never seen anything like this before... please watch this video to see how slow posts are loading:

http://youtu.be/Y384pTeUc8s

Any suggestions? Like I said, I tried completely "fresh" WordPress installations but I get the exact same behavior.
  • 0

#2 MikeDVB

MikeDVB

    Forum Administrator

  • Staff Administrator
  • PipPipPipPipPip
  • 2,889 posts
  • Gender:Male
  • Location:Central Indiana, USA

Posted 04 November 2012 - 08:36 PM

I was able to reproduce the issue - I disabled all plugins and the issue disappeared entirely and everything worked as fast as expected. I then re-activated all of the previously enabled plugins, and the speed continued to remain. I suspect a bug or issue in one of your plug-ins - if it were a server issue, it wouldn't have changed when I disabled your plugins.
  • 0
Michael Denney - MDDHosting LLC - Providing Hosting since 2007
Scalable shared hosting plans in the cloud! Check them out!
Highly Available Cloud Shared, Reseller, and VPS
http://www.mddhosting.com/

#3 MikeDVB

MikeDVB

    Forum Administrator

  • Staff Administrator
  • PipPipPipPipPip
  • 2,889 posts
  • Gender:Male
  • Location:Central Indiana, USA

Posted 05 November 2012 - 12:06 AM

Upon further investigation, I was able to reproduce this issue in a vanilla WordPress blog that I created for testing purposes. I created 22 posts that were 120 paragraphs totaling 10,712 words and 72.1 KB each.

We performed some additional optimization on our MySQL Configuration based upon the current usage. I believe part of the problem was some cache figures that were actually set too high. The system was spending more time searching those caches than it would take to serve the request directly and then when there was a cache miss it still had to serve the request direct.

Along the way we've also adjusted the Query Cache settings a bit, upping the overall cache and upping the query size that can be cached. It's possible that further optimization will be required, as we need to allow at least 24 hours but preferrably a week or two in-between to see how things are performing statistically to identify what changes need to be made.

If you have any questions at all, let us know.
  • 1
Michael Denney - MDDHosting LLC - Providing Hosting since 2007
Scalable shared hosting plans in the cloud! Check them out!
Highly Available Cloud Shared, Reseller, and VPS
http://www.mddhosting.com/

#4 Flix

Flix

    Newbie

  • Members
  • Pip
  • 14 posts

Posted 05 November 2012 - 12:25 AM

Problem fixed in record time! Amazing support; thank you!!!

Happy customer!
:) :) :)
  • 0





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users